Bugzilla and MySql errors

by , under Apple, Unix

First off, if you’re trying to install Bugzilla 4.x on 10.5 server, don’t. At least as of Bugzilla version 4.0, it just won’t complete the localconfig script properly. Go back to version 3.6.4 and try again.

If you’re seeing the following when trying to actually log in to Bugzilla try the solution below.

[error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: install_driver(mysql) failed: Can’t load ‘/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBD/mysql/mysql.bun
dle’ for module DBD::mysql: dlopen(/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBD/mysql/mysql.bundle, 1): Library not loaded: libmysqlclient.18.dylib
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: Referenced from: /Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBD/mysql/mysql.bundle
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: Reason: image not found at /System/Library/Perl/5.8.8/darwin-thread-multi-2level/DynaLoader.pm line 230.
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: at (eval 42) line 3
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: Compilation failed in require at (eval 42) line 3.
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: Perhaps a required shared library or dll isn’t installed where expected
[Sun Mar 27 00:44:00 2011] [error] [client 192.168.50.2] [Sun Mar 27 00:44:00 2011] config.cgi: at Bugzilla/DB.pm line 1101

Try this- ln -s /usr/local/mysql/lib/libmysqlclient.18.dylib /usr/local/lib/libmysqlclient.18.dylib

Leave a Reply